Le forum consacré à ToolsX

Le bon génie de votre Mac
 
AccueilAccueil  FAQFAQ  RechercherRechercher  S'enregistrerS'enregistrer  MembresMembres  GroupesGroupes  Connexion  

Partagez | 
 

 Exception of class NilObjectException [Résolu]

Voir le sujet précédent Voir le sujet suivant Aller en bas 
AuteurMessage
philippe99



Nombre de messages : 6
Date d'inscription : 04/02/2006

MessageSujet: Exception of class NilObjectException [Résolu]   Sam 4 Fév à 20:33

Bonjour le Squale.
G5 10.4.4 ToolsX 3.6
1ère installation et 1er lancement;
Système>Optimisation: si je clique sur "Afficher le journal système de ce script" (pour le quotidien ou l'hebdomadaire), je reçois cette erreur:

http://img483.imageshack.us/my.php?image=screenshot013ye.png

(An exception of class NilObjectException was not handled)
Et l'appli se ferme.

J'ose supposer que cela est du au fait que je n'ai pas encore fait de maintenance sous ToolsX 3.6 (le fait tous les jours sous 3.4).
Mais bon, j'attends que tu me rassures..je continue à utiliser le bon vieux 3.4

Phil
Revenir en haut Aller en bas
Voir le profil de l'utilisateur
Admin
Admin


Nombre de messages : 69
Age : 43
Localisation : 78
Date d'inscription : 18/10/2005

MessageSujet: Re: Exception of class NilObjectException [Résolu]   Dim 5 Fév à 2:21

Intéressant… >Clà signifie que le susytème n'a pas créé de rapport concernant les scripts de maintenance… Je n'avais pas ongé à celà et la nouvelle version de ToolsX cherche donc (désespérement) ce rapport inexistant…

Vivement la MAJ Wink


Celà ne change rien au comportement de ToolsX et à son efficacité…
Revenir en haut Aller en bas
Voir le profil de l'utilisateur http://toolsx.forumpro.fr
philippe99



Nombre de messages : 6
Date d'inscription : 04/02/2006

MessageSujet: Re: Exception of class NilObjectException [Résolu]   Dim 5 Fév à 12:08

Admin a écrit:
le système n'a pas créé de rapport concernant les scripts de maintenance… J

"Est-ce grave docteur" ?
Sérieusement, il faut activer un flag pour cela ? Eventuellement via le mode "Debug" ?
C'est étrange car normalement sous tout Unix normalement constitué, les actions d'un crontab (qu'il soit de root ou perso) génère un log (c'est le cas sur ma SUN)..ou alors l'admin au boulot a activé une option.
Je vais un peu aussi chercher de mon coté sur les forums Unix.

Merci
Phil
Revenir en haut Aller en bas
Voir le profil de l'utilisateur
Admin
Admin


Nombre de messages : 69
Age : 43
Localisation : 78
Date d'inscription : 18/10/2005

MessageSujet: Re: Exception of class NilObjectException [Résolu]   Dim 5 Fév à 17:26

Attention : Avec MacOS X 10.4, Apple ne passe plus par le Crontab mais par un système maison…
Revenir en haut Aller en bas
Voir le profil de l'utilisateur http://toolsx.forumpro.fr
philippe99



Nombre de messages : 6
Date d'inscription : 04/02/2006

MessageSujet: Re: Exception of class NilObjectException [Résolu]   Dim 5 Fév à 21:23

Admin a écrit:
Attention : Avec MacOS X 10.4, Apple ne passe plus par le Crontab mais par un système maison…
Là d'accord.
Formi'd: alors qu'il y a un outil assez simple (mais assez rustique) de programmation d'actions, v'là qu'Apple cherche à redécouvrir la poudre. Crying or Very sad

Maintenant, je comprends mieux le 'nilException' du problème puisque le Tigre ne lance plus le crontab classique
Phil
Revenir en haut Aller en bas
Voir le profil de l'utilisateur
Admin
Admin


Nombre de messages : 69
Age : 43
Localisation : 78
Date d'inscription : 18/10/2005

MessageSujet: Re: Exception of class NilObjectException [Résolu]   Dim 5 Fév à 22:14

Tout à fait d'accord avec toi philippe99… Apple a su "piquer" dans l'OpenSource et tente maintenant (en tout cas c'est l'impression que ça donne) de "reverrouiller" son OS… affraid No
Revenir en haut Aller en bas
Voir le profil de l'utilisateur http://toolsx.forumpro.fr
Contenu sponsorisé




MessageSujet: Re: Exception of class NilObjectException [Résolu]   

Revenir en haut Aller en bas
 
Exception of class NilObjectException [Résolu]
Voir le sujet précédent Voir le sujet suivant Revenir en haut 
Page 1 sur 1
 Sujets similaires
-
» [Résolu] [XHTML] Besoin d'aide simple avec div class="aside"
» exception unknown software avec Antivir, que faire ? (résolu)
» [Résolu] Mot de passe smtp
» [Résolu] MSN vérolé
» [résolu]pc infecté par wwwzuc32.exe

Permission de ce forum:Vous ne pouvez pas répondre aux sujets dans ce forum
Le forum consacré à ToolsX :: Rapport de bug-
Sauter vers: